You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
This repository was archived by the owner on Jul 26, 2026. It is now read-only.
Repository navigation
This repository was archived by the owner on Jul 26, 2026. It is now read-only.
Is it possible to bump the smmap version to 5.0.0?
It is the current version in ArchLinux repository and this is breaking packages depending on gitdb like git-up.
I tried to bump the smmap version. Tests passed with smmap-5.0.0 on ArchLinux.
Oh, we are in gitdb, never mind 😅. This means you would also need a gitdb version bump, right?
Also it's strange that a major version bump is able to break anything, as it currently is not used by anybody. The requirements here say smmap>=3.0.1,<5, so it shouldn't pick it up.
Maybe you can help shed some light on what happens there.
@Byron This is my point. Requirements of gitdb is locking smmap version as smmap>=3.0.1,<5. Meanwhile smmap-5.0.0 is released and included to the current Arch packages. That is making gitdb failing on my system. I ran the gitdb unit tests with smmap-5.0.0 and tests passed. What I'm asking is to update the requirements.txt here as smmap>=3.0.1,<=5 or whatever else supporting 5.0 release.
I am happy to do that! This also means the bug was introduced in the arch package manager which seems to pair incompatible crates while not trying to rebuild all dependencies with the new version, potentially causing widespread breakage, not only with GitPython.
v4.0.8 was released, avoiding to major bump this one to avoid similar issues to arise on arch. By now I feel there is no way to do it right.
I am closing this issue as new version constraints were set to include smmap 5.0, and also drop support for py3.4 and 3.5 to match smmap.
Activity
Byron commentedon Oct 20, 2021
Sorry for the hassle. It looks like pypi already has 5.0, but due to me not having pushed the changes these were not present here.
Now
masterhas the version change, does that help?Byron commentedon Oct 20, 2021
Oh, we are in
gitdb, never mind 😅. This means you would also need a gitdb version bump, right?Also it's strange that a major version bump is able to break anything, as it currently is not used by anybody. The requirements here say
smmap>=3.0.1,<5, so it shouldn't pick it up.Maybe you can help shed some light on what happens there.
DmitryKuzmenko commentedon Oct 22, 2021
@Byron This is my point. Requirements of gitdb is locking smmap version as
smmap>=3.0.1,<5. Meanwhilesmmap-5.0.0is released and included to the current Arch packages. That is makinggitdbfailing on my system. I ran thegitdbunit tests withsmmap-5.0.0and tests passed. What I'm asking is to update therequirements.txthere assmmap>=3.0.1,<=5or whatever else supporting 5.0 release.Allow usage of smmap 5.0 (#76)
Byron commentedon Oct 23, 2021
I am happy to do that! This also means the bug was introduced in the arch package manager which seems to pair incompatible crates while not trying to rebuild all dependencies with the new version, potentially causing widespread breakage, not only with GitPython.
v4.0.8 was released, avoiding to major bump this one to avoid similar issues to arise on arch. By now I feel there is no way to do it right.
I am closing this issue as new version constraints were set to include smmap 5.0, and also drop support for py3.4 and 3.5 to match smmap.